RangeRovers.net Forum banner

3000

  1. P38 wont past 3000 rpm

    Range Rover Mark II / P38
    Hi I have this problem for a few weeks. And the first thine i chack is the fuel pump. So i found that is a littel bit weak so i had it replaced. But the problem isn't solved. What can be the couse? Cumshaft sensor ? I dont have any fualt on the dash. Thanks
  2. 3000 RPM limiter? 1996 Range Rover 4.6L

    Range Rover Mark II / P38
    I have a 1996 Range Rover 4.6 HSE and I seem to have some type of limiter at 3000 RPM? When in park or neutral the revs will go to just over 3000 RPM (approx. 3250 RPM) and will jump from there to approx. 2750 RPM. When driving it will go to 3000 and will not allow the engine to exceed that. You...
  3. Revs increasing to 3000 on climb out of village. - Any Ideas???

    Range Rover Mark III / L322
    Revs increasing to 3000 on climb out of village. - Any Ideas??? OK, last week my wife was driving our L322 (2003 4.4 Petrol) into Salisbury from Devizes. Through one of the villages (Shrewton) there is a slight hill as you are coming out of the village. Normally the car drops down a gear...
  4. TekPro 3000 - anyone using it? Maybe similar to Lynx?

    Diagnostic Equipment
    The TekPro 3000LR has been out from AtlanticBritish from some time now, but I still haven't seen any decent reviews about its functionality. Anyone using it? It is a bit pricey but they keep having 'sales' and I am tempted to try it. It comes unlocked for all rover vehicles and is a stand-alone...
  5. P38 hill climb RPM drops when hits 3000.

    Range Rover Mark II / P38
    Hello, I have a 1997 range rover 4.0SE P38. I noticed whenever i am driving up steep hills it really starts to struggle, and it cant even really accelerate up the hills. when i apply more pressure to the pedal the rpm's will increase to about 3000 and then suddenly drop off to 2500, the engine...
  6. Runs but at about 3000 rpm breaks down as if something limiting it

    Range Rover Mark II / P38
    Runs but at about 3000 rpm breaks down as if something limiting it Just done head gasket and took out for a drive runs sweet but at about 3000 rmp engine runs lumpy and no powerUpto 3000rmp it is faultlessPlease can someone help I have changed plugs etc
Top