RangeRovers.net Forum banner

Recent content by PBRR

  1. L322 Code Reader Not Working, Reads "LINK ERROR"

    Diagnostic Equipment
    Re: L322 Code Reader Not Working, Reads "LINK ERROR" Which fuses are the diagnostic ones? Can't seem to find them. My #37 in the glove box was missing so I placed a 5a in it but that made no difference. The reader is getting power, just not connecting. Thanks for any input!
  2. L322 Code Reader Not Working, Reads "LINK ERROR"

    Diagnostic Equipment
    About an hour after I changed my oil my SES light came on. Probably not related to the oil change but I thought I'd share anyways. When I plug my OBD2 Reader in I get the message "LINK ERROR". Is there a certain way to connect the reader? I've tried reading the code with the key in aux position...
  3. Hot on one side, Cold on the other

    Range Rover Mark III / L322
    Well I ended up figuring it out. It was the fill tool that I was using. I tried everything else then finally came back to "what if both fill tools I used were messed up". So I went down to the auto parts store and bought the most expensive can and gauge combo (only $45). I went out to the...
  4. Hot on one side, Cold on the other

    Range Rover Mark III / L322
    Hello everyone, I am having the same cold on the left, hot on the right problem. I have a 2006 full size supercharged. I checked my freon, picked up a can with a gauge from the auto parts store. The gauge read about 30 and would not accept anymore freon. So then I moved to the coolant valve...
Top