No Nav Screen, No sound from head unit in any mode
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 5 of 5

Thread: No Nav Screen, No sound from head unit in any mode

  1. #1
    FRESHMAN ROVER
    Join Date
    July 28th, 2006
    Location
    Northern Virginia
    Posts
    112

    No Nav Screen, No sound from head unit in any mode

    Im stumped. Drove to work today no issues whatsoever. Its a 2006 sc i have owned since new and has 65K on it and really havent had any major issues. I left work turned on the head unit and it showed SAT1 no channel and no sound. The nav screen had the LR logo on it and wouldnt change. tried shutting it down and waiting 1 minute and restarting. Now I have nothing on the nav screen and no sound in any mode from the head unit.
    Im stumped. Ideas and suggestions are welcomed!


    Thanks all.
    Last edited by RRToadHall; March 20th, 2012 at 07:56 PM.
    06 RRS S/C Zermatt Silver
    06 997C2S Cabrio, Triple Black
    91 300ZX NA, Black

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    Premium Member dantheman1's Avatar
    Join Date
    November 18th, 2010
    Location
    West Palm Beach, FL
    Posts
    741

    Re: No Nav Screen, No sound from head unit in any mode

    If you've never changed your battery before, I would get it checked and probably changed out. The hifi system is very picky to voltage, a slight drop will cause it to shut down. To get the radio/nav to work, just disconnect the neg battery terminal cable and wait 5-10min then reconnect. Should restart the systems.
    2011 RRS Supercharged, Santorini Black on Tan, ATB front and side grilles
    2008 RRS HSE Lux (sold), Alaska white on Ivory/Ebony, Supercharged front and side grill's,
    20" genuine stormer wheels, Supercharged front Brembo brake retrofit, Supercharged exhaust tips retrofit, 2010+ tail lights retrofit, Nappa leather steering wheel retrofit.
    2005 LR3 HSE (sold), Java Black on Alpaca, oversized all-terrains, LR genuine expedition roof rack, grille guard, and tail lamp guards.

  4. #3
    FRESHMAN ROVER
    Join Date
    July 28th, 2006
    Location
    Northern Virginia
    Posts
    112

    Re: No Nav Screen, No sound from head unit in any mode

    Thanks. All fixed. For now!
    06 RRS S/C Zermatt Silver
    06 997C2S Cabrio, Triple Black
    91 300ZX NA, Black

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FORUM MODERATOR sblvro's Avatar
    Join Date
    March 12th, 2012
    Location
    Little Rock, Arkansas
    Posts
    1,964

    Re: No Nav Screen, No sound from head unit in any mode

    Quote Originally Posted by bogart101 View Post
    Thanks. All fixed. For now!
    what fixed it?
    http://forums.evolutionm.net/members/596-sblvro.html

    https://www.facebook.com/pages/doctorownedcarscom/217367714961131

    2
    011 RRS hse lux (traded),2013 RRS hse lux +silver, vision package(current),2009 escalade hybrid(traded) for 2015i escalade platinum,2014 glk 350 4matic(current)

  7. #5
    NEWBIE
    Join Date
    September 5th, 2012
    Location
    Nigeria
    Posts
    1

    Re: No Nav Screen, No sound from head unit in any mode

    Hi, I tried changing the battery and waited 10 minutes before fixing the new battery still no head way. Other options please

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. New Head Unit
    By bluemini300 in forum Range Rover Mark II / P38
    Replies: 18
    Last Post: September 6th, 2011, 02:12 PM
  2. Changing head unit
    By luvs2getmuddy in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: December 25th, 2009, 06:17 PM
  3. 91 RRC head unit replacement
    By rover4x4 in forum Range Rover Classic
    Replies: 0
    Last Post: July 10th, 2009, 07:26 PM
  4. new head unit and amp
    By drivingpartnership in forum Range Rover Mark III / L322
    Replies: 2
    Last Post: April 6th, 2008, 12:58 PM
  5. Suspension grinding sound in access mode?
    By Slykmr in forum Range Rover Sport / L320
    Replies: 5
    Last Post: March 17th, 2006, 04:37 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0