L320 2007 Errors after Transmission overhaul
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: L320 2007 Errors after Transmission overhaul

  1. #1
    WTh
    WTh is online now
    FRESHMAN ROVER
    Join Date
    March 5th, 2019
    Posts
    6

    Question L320 2007 Errors after Transmission overhaul

    Automatic Transmission is completely overhauled by specialised company.
    After installation of the Transmission, few errors occur.
    1. Not always immediate traction when put in 'D' or 'R'; switching engine on/off does mostly help, sometimes just waiting solves it.
    2. During driving after few kilometers, error message 'Transmission fault' in message centre; transmission functions normally
    3. Sometimes OBDII error code P0741 - Torque Convertor Clutch Circuit Performance or Stuck off. I think this happens when accelerating fast.

    Company that did the overhaul claims that the transmission has no errors, hence it should be in something else; cabling / connectors / etc.

    Questions:
    1. How to diagnose / problem finding in cabling and connectors?
    2. Does anybody had similar problems, and what did resolve the issue.

    Support / input highly appreciated.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    October 20th, 2018
    Posts
    23

    Re: L320 2007 Errors after Transmission overhaul

    what company did the overhaul?

  4. #3
    WTh
    WTh is online now
    FRESHMAN ROVER
    Join Date
    March 5th, 2019
    Posts
    6

    Re: L320 2007 Errors after Transmission overhaul

    a Dutch company, specialised in automatic gearbox repairs / overhaul, including the ZF transmissions

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    JUNIOR ROVER garrycol's Avatar
    Join Date
    September 19th, 2013
    Location
    Canberra - Australia
    Posts
    504

    Re: L320 2007 Errors after Transmission overhaul

    After all that work - has the gearbox ECU been reset? In its simplest form the ECU may have evolved/learned to the old gearbox settings so is expecting readings that are now different with the new gearbox - get the gearbox ECU reset and see if that does the trick. Is the easiest and cheapest thing to do before having to pull things apart searching for problems.

    garry
    Range Rover Sport
    2.7 TDV6

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0