2011 Sport SC L320 suspension issues problems - no faults
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 10 of 10

Thread: 2011 Sport SC L320 suspension issues problems - no faults

  1. #1
    FRESHMAN ROVER
    Join Date
    June 11th, 2019
    Location
    Syracuse, NY
    Posts
    11

    2011 Sport SC L320 suspension issues problems - no faults

    Hi all,

    I purchased a 2 owner 2011 Sport Supercharged about a month ago with 69k miles on it. It has been... interesting. I just read nearly 50 threads on EAS problems, and don't think I've seen one quite like this.

    EAS worked great, switches to all modes and heights very quickly, no issues what-so-ever.

    Yesterday I jacked the car up to add some HR spacers to all four corners. Just 15mms in the front and 25mms rear. At one point doing the fronts, I believe I turned the car on to rotate the wheel in order to be able to inspect the sway bar link ends more carefully.

    I finished and began to drive the car like normal for the rest of the day. One time, I noticed when I turned it on, the indicator said it was in off road height, even though I hadn't pressed it and the car was clearly at standard height. Another time I turned it on and it did the same thing, but also said it was in sand mode, even though I hadn't done that either. Changing the suspension settings worked like normal and making go up or down seemed to fix the issue.

    Later that day I was sitting in my driveway looking at the garage door and I tried to raise the car to off road height. The rear immediately raised like normal (in a few seconds) and the front wasn't moving. The 4x4 screen would constantly read "raising" even though nothing was happening. I lowered it back down to standard and took it for a ride around the block. I stopped a couple of times and tried to raise the suspension. Rear would pop right up but not the front. Then I drove it and put it in access height and then nothing would raise up, even when when i drove it up to 40 mph. No faults or errors of any kind.

    Some time later time, I got a message that said suspension will raise when cool, or something like that. I parked the car in the garage and came back an hour later. Started the car and tried to raise it to standard. Back came right up, front did too after an extremely long time, like 60 - 120 seconds. Left it in standard and shut it off. Came back 8 hours later and tried to raise it to off road. Back end popped right up in a few seconds and front took over 60 seconds to raise to the correct off-road height, but seemed fine when it was there. Left it overnight and this morning it was right in the same spot. Super symmetrical ground to fender, and hadn't even dropped a cm.

    the weirdest part of all of this is at no point did I get and error code or fault. Not even the suspension raising slowly one I've read about. The only thing was that cooling message. So I am not really sure where to start. I have a really hard time believing this was an unrelated coincidence with me jacking the car. Is there a way to reset the suspension? Could the position sensors somehow been disturbed when I took the wheels off?

    - seems to be no leaks
    - compressor seems to work fine, because rear raises in a few seconds
    - fronts take 60+ seconds to raise
    - no faults or messages at all
    - holds air all night

    I am not expecting a diagnosis, but I am hoping someone could provide guidance on when to begin and what to check in what order.

    Thank you in advance for the help. best.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER sowr's Avatar
    Join Date
    October 31st, 2017
    Location
    Big Bear Lake
    Posts
    248

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    If the info screen says "Raising" that means that the compressor is trying to lift the suspension but can't for some reason, usually a leak somewhere in the front part of the system, the eventual message of "suspension will raise when cool" is an indicator that the compressor overheated trying to bring the front up - if this happens often it won't be good for the compressor. What are HR spacers? AS it seems adding those initiated the problem. Sometimes an airbag may be leak free when in access or normal mode but when raised may reveal a leak.
    Range Rover HSE 2010 (5.0L V8 NA) with Factory Roof Rack - Zermatt Silver, Black Interior.

  4. #3
    FRESHMAN ROVER
    Join Date
    June 11th, 2019
    Location
    Syracuse, NY
    Posts
    11

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    HR is the brand name, the TRAK+ 25mm models, these:

    https://www.ebay.com/itm/H-R-25mm-Silver-Wheel-Spacers-for-2010-2016-Land-Rover-Range-Rover-Sport/401566782301?hash=item5d7f3ed35d:g:VcQAAOSwojdbR9r-

    If the car sits overnight, it doesn't seem to lose any air. Unless the car will run the compressor when the ignition is off?

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    JUNIOR ROVER garrycol's Avatar
    Join Date
    September 19th, 2013
    Location
    Canberra - Australia
    Posts
    504

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    Did you recalibrate the suspension after adding the spacers - if not that is most likely your problem.
    Range Rover Sport
    2.7 TDV6

  7. #5
    FRESHMAN ROVER
    Join Date
    June 11th, 2019
    Location
    Syracuse, NY
    Posts
    11

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    Ok, sweet, some happy news here. I raised the car to off road, and then I took the spacers off by jacking up each corner one at a time, like I did putting them on. When I was done this left the car floating way above off road height with some serious positive camber. I got in, started the car and it asked me "confirm desired ride height" (good car!). I set it to standard and drove it around a bit, then parked and hit off road and it popped right up into position in a few seconds just like normal. Seems to work fine now.

    I can't imagine how the spacers could have possibly affected this. Wheel spacers should only chance scrub radius (a lot), camber (a tiny bit), spring rate (a tiny bit), and roll center (a bit). The last is only affected when cornering. I really feel like I got the car discombobulated when I jacked it up, then turned it on to move the wheel. I may try the spacers again next weekend. This car makes my 911s seem simple. Coincidentally porsche does and has shipped gt3s and turbos with up to 18mm wheel spacers on them as an option.

  8. #6
    FRESHMAN ROVER
    Join Date
    June 11th, 2019
    Location
    Syracuse, NY
    Posts
    11

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    Quote Originally Posted by garrycol View Post
    Did you recalibrate the suspension after adding the spacers - if not that is most likely your problem.
    No, how do I do that? I searched all over for the answer to recalibrating and every thread that came up was about that aftermarket EAS tool.

  9. #7
    JUNIOR ROVER garrycol's Avatar
    Join Date
    September 19th, 2013
    Location
    Canberra - Australia
    Posts
    504

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    Yes that will be needed - if you don't have the right Gap Tool/Fault mate etc then you will need to get your independent land rover agent to do it. Comes with the territory, if you make changes to the suspension then you need to recalibrate.

    Me, if I want higher height I just push the button to my LLAMs system and raise the car to the height I want - no permanent arrangement that requires calibration and wears the CVs. At the normal onroad setting I can go to +35mm or to about +50mm (both of which are higher than your spacers) at the touch of a button. Likewise I can go lower as well.

    Yes if you want to run the spacers fault free then you probably need to get the car suspension calibrated professionally.

    Oh if you wanted a permanent lift why did you decide to go spacers over say "johnson" rods - achieve your same lift but no recalibration required and a quick 5 minute revert to "normal" if required?

    Garry
    Range Rover Sport
    2.7 TDV6

  10. #8
    FRESHMAN ROVER
    Join Date
    December 1st, 2016
    Location
    Lake Elsinore,Ca
    Posts
    129

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    He is talking wheel spacers guys not suspension. No calibration is needed. Would not generally have anything to do with the suspension/EAS system.

    Unclear information from the OP led this sideways.

  11. #9
    JUNIOR ROVER garrycol's Avatar
    Join Date
    September 19th, 2013
    Location
    Canberra - Australia
    Posts
    504

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    Oh dear - I completely misunderstood - ignore all my comments above then.

    Wheel spacers will have no impact on the EAS, so is a coincidence.
    Range Rover Sport
    2.7 TDV6

  12. #10
    FRESHMAN ROVER
    Join Date
    June 11th, 2019
    Location
    Syracuse, NY
    Posts
    11

    Re: 2011 Sport SC L320 suspension issues problems - no fault

    Quote Originally Posted by Special Ed View Post
    He is talking wheel spacers guys not suspension. No calibration is needed. Would not generally have anything to do with the suspension/EAS system.

    Unclear information from the OP led this sideways.
    I attempted to answer that we were talking about wheel spacers immediately after my initial post, however I got a message that the post would have to be approved by a moderator. That message never posted, but for some reason my next two did without needing to be approved. The initial post had to be approved as well.

    I had no idea suspension spacers were even a thing for this car.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0