noise on start up
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 7 of 7

Thread: noise on start up

  1. #1
    FRESHMAN ROVER
    Join Date
    May 10th, 2019
    Location
    Perth, Western Australia
    Posts
    13

    noise on start up

    I have a 2009 MY10 V6 3.0L Diesel,Range Rover Sport 150km. Its a bit rattly on start up sometimes for around 3 secs hot or cold, is this normal for a diesel V6 ? It runs fine, just wondering how I can eliminate the start up noise, sounds dodgy. I've just changed the oil 5W/30 Diesel Penrite oil & filter, it slightly quietened it down, Is this normal or can something be done to eliminate this noise ?

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    May 2nd, 2019
    Location
    Buffalo NY
    Posts
    6

    Re: noise on start up

    Every diesel ive ever been around is loud on startup. On most if not all diesels the pistons are forged and because they expand slower than cast you get piston slap until they warm up. Basically the skirts of the pistons hit the cylinder walls.

  4. #3
    FRESHMAN ROVER
    Join Date
    May 10th, 2019
    Location
    Perth, Western Australia
    Posts
    13

    Re: noise on start up

    Yeh ok,thanks for that info, just doesn't sound healthy, it sometimes does it when its warm, but Its more like a lifter/tappet noise.

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    SOPHOMORE ROVER garrycol's Avatar
    Join Date
    September 19th, 2013
    Location
    Canberra - Australia
    Posts
    494

    Re: noise on start up

    This is a great US site but diesel LRs here are as rare as rocking horse poo.

    Why no go to our own aussie LR forum www.AULRO.com and you will get all the diesel specific information you need.

    As to your question - it is a diesel - by their very nature they are rattly. Also it does take a couple of seconds for full oil pressure to develop so if it is rattling while the oil pressure light is still on at start dont worry about it - however if it is rattly when the oil pressure light is off you need to get it checked.

    Garry
    Range Rover Sport
    2.7 TDV6

  7. #5
    FRESHMAN ROVER
    Join Date
    June 5th, 2018
    Posts
    153

    Re: noise on start up

    One suggestion I might make: Make sure that your oil filter has a one way valve in it. That component keeps the oil filter filled when the engine is shut down. If the filter empties itself after shutdown, it will need to refill itself before oiling the rest of the engine., That will take a few seconds, and the engine is essentially running dryuntil the filter fills. Ray

  8. #6
    FRESHMAN ROVER
    Join Date
    May 10th, 2019
    Location
    Perth, Western Australia
    Posts
    13

    Re: noise on start up

    I didn't get a genuine filter do they have a one way valve in the filter or the filter housing ?

  9. #7
    SOPHOMORE ROVER garrycol's Avatar
    Join Date
    September 19th, 2013
    Location
    Canberra - Australia
    Posts
    494

    Re: noise on start up

    The filter irrespective of the make fits your engine so is correct - whether it has a valve or doesn't is irrelevant - it is correct for the engine.
    Range Rover Sport
    2.7 TDV6

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. Compressor noise on start up.
    By Shockerg1 in forum Range Rover Sport / L320
    Replies: 11
    Last Post: January 17th, 2015, 11:40 AM
  2. noise at start up and under under acceleration
    By rangerover04 in forum Range Rover Mark III / L322
    Replies: 2
    Last Post: November 23rd, 2012, 09:20 AM
  3. Replies: 4
    Last Post: October 19th, 2012, 02:50 PM
  4. Loud knocking noise on start up
    By isleofbones in forum Range Rover Mark III / L322
    Replies: 2
    Last Post: May 20th, 2012, 10:20 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0