2013 Sport Air Conditioner quit working
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 2 of 2

Thread: 2013 Sport Air Conditioner quit working

  1. #1
    NEWBIE
    Join Date
    May 1st, 2019
    Posts
    2

    2013 Sport Air Conditioner quit working

    I was driving home earlier this week on the interstate and my AC started emitting a chemical type smell and then the A/C system shut down. The entire system is no longer blowing any air, AC, or heat. Has anyone had a similar experience?

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    July 8th, 2017
    Location
    Venice, CA
    Posts
    46

    Re: 2013 Sport Air Conditioner quit working

    Probably the blower motor and resistor have failed. There should be many posts on here regarding fixing it (fairly easy replacement).

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. 2013 Range Rover Sport Air Conditioner issue
    By resparover in forum Range Rover Sport / L320
    Replies: 0
    Last Post: May 1st, 2019, 11:00 AM
  2. 2013 Evoque Air conditioner Random problem
    By Ariel in forum Range Rover Evoque / L538
    Replies: 0
    Last Post: February 2nd, 2018, 01:06 PM
  3. FM radio decided to quit working??!?!?!
    By JF5885477 in forum Range Rover Mark III / L322
    Replies: 8
    Last Post: April 22nd, 2008, 07:02 PM
  4. Fog lights quit working.......
    By lfagan in forum Range Rover Classic
    Replies: 5
    Last Post: May 16th, 2006, 12:11 PM
  5. Fog lights quit working need fuse and relay location
    By lfagan in forum Range Rover Classic
    Replies: 1
    Last Post: February 27th, 2005, 06:34 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0