RR sport won’t start
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 5 of 5

Thread: RR sport won’t start

  1. #1
    FRESHMAN ROVER Kami143's Avatar
    Join Date
    August 4th, 2018
    Location
    Manchester
    Posts
    3

    Arrow RR sport won’t start

    Bought a Range Rover 2010 facelift but won’t start
    ignition is ok ...
    when press ignition car cranks ( bit slow )...
    turnining over the engine ...
    fuel pressure is ok ......
    no lights illuminate on the dashboard.....
    diagnostic computer shows no fault .....
    sometines show on computer random faults and no communication with the engine ....

    we couldn’t find it out what the real fault is, my mechanic checked and firstly suspected it’s injectors not giving fuel ,changed one side 3 injectors but still no start ,now he suspects it could be engine gone and asking for engine rebuild or replace ,I can’t believe that it’s engine gone.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER rjsimmons's Avatar
    Join Date
    July 17th, 2017
    Location
    Fredericksburg, VA
    Posts
    106

    Re: RR sport won’t start

    Check your battery CCA (Cold Cranking Amps).

    After that, check your alternator output.
    "The tree of liberty must be refreshed, from time to time, with the blood of patriots and tyrants." - Thomas Jefferson
    2013 RRS Supercharged Fuji White

  4. #3
    FORUM MODERATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Kloshe Lodge, Shelter Bay, Washington
    Posts
    27,612

    Re: RR sport won’t start

    My post from this morning is not showing. RJ just pointed at two items on my basics list. Battery and Alternator. Of course both can be brand new and if you have dirty cables or a cable failing due to too much resistance nothing is going crank the engine fast enough to fire.

    Now as far as thinking this was all cause by bad injectors... why did they not test them? Fuel pressure is "ok"? Did they actually test the pressure or just see if there was fuel at the rail. Lack of fuel, dirty injectors etc have nothing to do with slow cranking. Slow cranking/low voltage is a sign of other issues.

    There is nothing above that even remotely suggests the engine is "gone". Any mechanic jumping from a slow crank to rebuilding or replacing the engine has not done his basic homework. At a minimum they need to do a compression check after resolving the slow crank. Chances are the battery is a one time replacement and just plain getting old or has a weak cell. Most shops do not clean BOTH ends of cables when replacing a battery. so your fuse box, alternator, starter and ground points can all be suspect for corrosion or loose connections.
    When dealing with yourself, act with your brain
    When dealing others, act with your heart.

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER
    Join Date
    January 4th, 2013
    Location
    Missouri
    Posts
    11

    Re: RR sport won’t start

    Check the fuse between the ECU and coils, mine was not blown but the contacts inside the fuse box had worn and the fuse was not making a connection. I chased this issue for months until i pulled the fuse to check it and thought it was a bit loose, I added some solder to the fuse pins and 12 months later the problem has never come back. I forget which number fuse it is but in the fuse box diagram it has an icon that looks like a coil of wire. I believe it's #6 and is 15 amps.

  7. #5
    FRESHMAN ROVER Kami143's Avatar
    Join Date
    August 4th, 2018
    Location
    Manchester
    Posts
    3
    Update - it was a broken camshaft chain and timing was out , had to get the engine rebuilt

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. Replies: 4
    Last Post: May 4th, 2015, 02:56 PM
  2. Won't start, won't shift out of park, new battery
    By SteveG in forum Range Rover Mark II / P38
    Replies: 24
    Last Post: March 21st, 2015, 07:39 AM
  3. 2009 RR Sport - Won't start - Codes P0340 & P0345
    By benjaminoste in forum Range Rover Sport / L320
    Replies: 8
    Last Post: November 1st, 2014, 11:14 AM
  4. Bad News :-( Truck won't start....cranks but won't turn over.
    By 06BlackHSE in forum Range Rover Mark III / L322
    Replies: 14
    Last Post: June 15th, 2013, 02:30 PM
  5. Old Key FOB Won't Unlock Doors, New Key FOB Won't Start Car... Ideas?
    By WBlackstone in forum Range Rover Mark III / L322
    Replies: 8
    Last Post: March 9th, 2013, 04:08 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0