electrical issues after installing new heater matrix
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: electrical issues after installing new heater matrix

  1. #1
    FRESHMAN ROVER taff101's Avatar
    Join Date
    May 18th, 2012
    Location
    Wales
    Posts
    49

    electrical issues after installing new heater matrix

    Old matrix spewed coolant inside so had to replace. Managed to removed dash and replace the matrix. All went back together and no leaks. Only problem is certain electrical equipment is now not working.

    Interior lighting
    Puddle lights on doors
    Bonet (hood) inside light
    Power mirrors
    heater blower
    lighting behind heater control panel
    Clock
    drivers seat motors


    Air con is working by the way

    Checked fuses, can't see any connections that have not been put back, obviously there is one common issue to stop these all from working?


    Thanks for any help!
    1969 series 2a truck cab 2 1/4 petrol
    1977 forward control 101 3.5 v8
    1992 range rover classic 3.9 v8
    2006 range rover sport 4.4 v8

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER taff101's Avatar
    Join Date
    May 18th, 2012
    Location
    Wales
    Posts
    49

    Re: electrical issues after installing new heater matrix

    always helps to look twice, found blown fuse, all good except heater bower not working. wiring from blower speed selector getting on the warm side
    1969 series 2a truck cab 2 1/4 petrol
    1977 forward control 101 3.5 v8
    1992 range rover classic 3.9 v8
    2006 range rover sport 4.4 v8

  4. #3
    SENIOR ROVER
    Join Date
    June 11th, 2016
    Location
    northern va 22003
    Posts
    1,407

    Re: electrical issues after installing new heater matrix

    have you double checked your ground points? the are at least 2 main grounds in the general area of the tunnel which if disturbed could cause issues.
    2k p38 4.6
    95 lwb 4.6
    01 d2 4.0

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER taff101's Avatar
    Join Date
    May 18th, 2012
    Location
    Wales
    Posts
    49

    Re: electrical issues after installing new heater matrix

    managed to remove both side covers to access the motor, with fan speed switched on motor gets hot but does not turn, can turn by hand so doesn't seem obstructed
    1969 series 2a truck cab 2 1/4 petrol
    1977 forward control 101 3.5 v8
    1992 range rover classic 3.9 v8
    2006 range rover sport 4.4 v8

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0