94 won’t start after alternator replacement
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 3 of 3

Thread: 94 won’t start after alternator replacement

  1. #1
    FRESHMAN ROVER
    Join Date
    October 24th, 2009
    Posts
    57

    94 won’t start after alternator replacement

    1994 4.2 began showing signs of the alternator dying, so I ordered a unit from British Parts of Utah.

    Prior to the replacement, the truck would start every time and there was no odd behavior besides the battery light coming on when idling. I put the battery on the charger and went about replacing the alternator with the new unit. The starter is getting power and will turn the engine over but it won’t start. The only thing that has changed is the alternator. Putting the old one back on and it still won’t start.

    How do I start diagnosing this? Is there something in the general area of the alternator that I could have inadvertently knocked loose?

    I checked the distributor, the cap has no play and the plug wires are all secure. I do not see anything in the area that’s unplugged.

    Thanks in advance!

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    SOPHOMORE ROVER
    Join Date
    February 18th, 2008
    Location
    Portland, Maine
    Posts
    301

    Re: 94 won’t start after alternator replacement

    Check the wires going to the ignition amplifier.
    Also, is your battery light coming on before you attempt to start?
    Kevin
    88 RRC "Audrey"

  4. #3
    FRESHMAN ROVER
    Join Date
    October 24th, 2009
    Posts
    57
    Quote Originally Posted by KK88RRC View Post
    Check the wires going to the ignition amplifier.
    Also, is your battery light coming on before you attempt to start?
    Thanks for the tip, I’ll check that tonight

    The battery light is on as soon as I turn the key to the first position before trying to start.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. Range Rover won’t turn over after new battery
    By blakerover in forum Range Rover Mark III / L322
    Replies: 9
    Last Post: October 30th, 2018, 03:41 PM
  2. Help RR won’t start after gearbox removal
    By Betiteh0777 in forum Range Rover Mark III / L322
    Replies: 12
    Last Post: June 12th, 2018, 06:02 AM
  3. 2007 RR/SC Won't Start After Alternator Replacement
    By MrRR in forum Range Rover Mark III / L322
    Replies: 8
    Last Post: October 23rd, 2017, 09:59 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0