1997 P38 Crank no start.
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: 1997 P38 Crank no start.

  1. #1
    FRESHMAN ROVER
    Join Date
    January 7th, 2019
    Location
    USA - Nassau County, NY
    Posts
    6

    1997 P38 Crank no start.

    Looking for help.

    I have been dealing with a no crank no CEL issue, as asked in my other posts.

    This weekend i decided to investigate further and removed the signal wire (Brown Red - RN) off the starter in order to check if i had 12 volts at key position II.
    With a helper at the wheel in order to turn the ignition key on, he then stated that i had a CEL.

    It now seems that there is continuous 12v to signal wire regardless of key position, in fact with no key in it is registering 12v.

    the other thing i noticed when testing for the 12v was that with the signal wire off and the key on, i could hear the fuel pump excite.

    SO it dawned on me to remove relay 19 out of the fuse box to check if it interrupted power which it did, when i put the relay back in and turned the key, i could hear the fuel pump again so tried to start. at this point i have crank no start.


    to summarize, i can repeat this cycle of crank no start and have the fuel pump excite. i checked for spark and fuel.

    fuel i have but there is no spark.

    In short it appears that something is interrupting the start cycle.

    I now throw it you guys for the answer.

    IS it the ignition switch?
    IS it the Immobilizer on the Ig Switch?
    IS it the BECM and ECM coding issue?

    What would keep 12v at the signal wire?
    HELP????

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    JUNIOR ROVER
    Join Date
    October 17th, 2017
    Location
    East England
    Posts
    675

    Re: 1997 P38 Crank no start.

    No CEL on a GEMS, which a 97 is, means the engine ECU has not been powered up by the BeCM as they have lost sync.
    97 4.0SE
    98 4.0 Police spec
    and a number of others I maintain for the owners.

  4. #3
    FRESHMAN ROVER
    Join Date
    January 7th, 2019
    Location
    USA - Nassau County, NY
    Posts
    6

    Re: 1997 P38 Crank no start.

    NO I have CEL. please reread my post.

    I have constant 12 volt at signal wire, this is stopping the cycle upon key turn. if i pullthe wire off the check engine light goes on.

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    SENIOR ROVER
    Join Date
    June 11th, 2016
    Location
    northern va 22003
    Posts
    1,295

    Re: 1997 P38 Crank no start.

    possible failed crank sensor.
    2k p38 4.6
    95 lwb 4.6
    01 d2 4.0

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. UPDATE: FIXED 94 4.2 LWB No Crank/No Click/No Start
    By patrianntics in forum Range Rover Classic
    Replies: 0
    Last Post: March 13th, 2017, 07:07 AM
  2. New to me P38 No crank, No Start.
    By rayodunne in forum Range Rover Mark II / P38
    Replies: 13
    Last Post: September 4th, 2013, 06:26 PM
  3. Replies: 12
    Last Post: May 25th, 2013, 09:34 AM
  4. HELP (please!)- Won't start, no crank, no CHECK ENGINE light
    By dave-the-diver in forum Range Rover Mark II / P38
    Replies: 19
    Last Post: January 22nd, 2007, 01:54 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0