EAS troubleshooting
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: EAS troubleshooting

  1. #1
    FRESHMAN ROVER
    Join Date
    April 7th, 2014
    Location
    Cape Town
    Posts
    4

    EAS troubleshooting

    Good day,

    I have rebuilt my valve block and replaced my compressor. Manually activating the pump via the ECU plug pins 1+8+26 - air is not reaching the tank as after 5 minutes I can remove all air lines without any sign of air loss. What valve needs to be checked directly after compressor / air drier and what path does it take? I wish for it too work as to manually test each air spring valve manually via pin 10+11 and 27+28. Thank you.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    Premium Member Escape's Avatar
    Join Date
    June 4th, 2007
    Location
    Belgium
    Posts
    1,184

    Re: EAS troubleshooting

    Start from the compressor and follow the airlines: first the blue one to the valve block, then the 8mm one to the bottom of the dryer, then back to the valve block. Most likely problem would be the diaphragm valve sticking open, you will feel the air the compressor tries to put into the tank exit through the exhaust filter, thus never reaching the tank. As a temporary fix, you can just block it to build pressure. Also check the airline from the valve block to the tank for leaks.

    Filip
    4.0 SE manual, 1997, 'Priscilla': current daily
    4.0 SE manual, 1995, 'Piper', built for offroad with tuned 4.6 on MS: lost in fire
    4.6 SE auto, 1995, 'Prue': awaiting attention
    2.5 DT manual, 1996, 'Paige': retired and stripped
    D90 TD5, 2005, 'Nessie' TR2 racer: sold

  4. #3
    FRESHMAN ROVER
    Join Date
    April 7th, 2014
    Location
    Cape Town
    Posts
    4

    Re: EAS troubleshooting

    Thanks for the reply Filip. I had a feeling the diaphragm solenoid is faulty as I cant hear the plunger actuating whilst running 12v though it. I have taken resistance readings from all solenoids and found this particular one to have a resistance 8x more than the others. 0.38Ω compared to the other 6x solenoids at 0.05Ω.

    Could someone independently verify if these readings are normal for the solenoids on a P38? The blue wires on the end solenoid are easily detached and tested for continuity.

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER
    Join Date
    April 7th, 2014
    Location
    Cape Town
    Posts
    4

    Re: EAS troubleshooting

    After some more trials on manual, I have discovered the air is reaching the tank and the air springs are actuating correctly - with the exception of the right rear spring which when inflated/deflated has the same effect to the left rear spring.

    NRV acting up? I have checked them several times and am thinking the Driver module is sending power to both solenoids so will test the right and left rear power usage on test bench. Out it comes again.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. **INFO** EAS Troubleshooting Tips
    By shupack in forum Range Rover Mark II / P38
    Replies: 61
    Last Post: January 29th, 2011, 07:44 AM
  2. EAS Compressor / Troubleshooting
    By wrldky in forum Range Rover Mark II / P38
    Replies: 7
    Last Post: July 9th, 2008, 12:58 PM
  3. EAS troubleshooting
    By rrdude in forum Range Rover Mark II / P38
    Replies: 10
    Last Post: March 28th, 2008, 02:52 AM
  4. EAS troubleshooting
    By KARamsay in forum Range Rover Mark II / P38
    Replies: 1
    Last Post: November 17th, 2005, 05:57 PM
  5. troubleshooting my EAS... Help needed :-)
    By iyada in forum Range Rover Mark II / P38
    Replies: 5
    Last Post: October 9th, 2005, 07:17 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0