2008 transmission limited gear error message
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 10 of 10

Thread: 2008 transmission limited gear error message

  1. #1
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16

    2008 transmission limited gear error message

    Have a 2008 range Rover. Getting the limited gear available and special programs not available error on dash. Tried clearing the codes and pulling the battery and the message comes back as soon as you turn the key to on. I also tried changing transmission pan, filter and connector sleeve. Also dropped the valve body and replaced the four tube seals and the bridge seal. Cleaned and refitted the transmission wire harness, no damage seen. Used SDD tool and got a P0657-00 on the TCM. Actuator supply voltage A - circuit/open. Any idea what this could be?

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    November 22nd, 2005
    Location
    Southern Oregon
    Posts
    189
    I’m not a transmission expert by any means but had a similar issue about a month ago with B circuit issue. Mine was fixed with replacing everything you replaced as well as the solenoids on the valve block
    https://www.rangerovers.net/forum/6-.../topics/334580
    I was a bit nervous going into the transmission and missed putting the shift selector slider in the correct position when putting the valve block back in.

    Been about a month now and all is well still.

    RRPhil and Mark_C were a huge help on getting me back running.
    1996 4.0 SE - "Lucky" has been a lucky car, 230,000 miles, owned for 18 years - recenly sold
    2000 4.6HSE - "Lotus". owned for 10 years now, just clicked 208,000 miles.
    2008 HSE 4.4l - "Meg" - New to us on 10-12-18 with 78,450 miles

  4. #3
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16
    I was thinking about that as well. But the research I have done says that the error relates to not being able to talk to any of the solenoids. I think it points to the Mechatronics unit possibly being bad. I bought this vehicle in an as is state. The transmission had been leaking fluid and lost drive. It was 4 quarts low when I got it and when I added the fluid I got drive back, but also the limited gear error. I have now fixed the leaking connector sleeve. The SDD says to check the word from the transmission harness to the shift interlock solenoid on the shifter. I'm not sure a bad shift solenoid would cause this. The resolution on the SDD is that either the shift interlock is bad or the TCM is bad

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16
    I was thinking about that as well. But the research I have done says that the error relates to not being able to talk to any of the solenoids. I think it points to the Mechatronics unit possibly being bad. I bought this vehicle in an as is state. The transmission had been leaking fluid and lost drive. It was 4 quarts low when I got it and when I added the fluid I got drive back, but also the limited gear error. I have now fixed the leaking connector sleeve. The SDD says to check the wire from the transmission harness to the shift interlock solenoid on the shifter. I'm not sure a bad shift solenoid would cause this. The resolution on the SDD is that either the shift interlock is bad or the TCM is bad

  7. #5
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16
    Just replaced the battery, it was bad. Same thing. Tested the wiring harness from the transmission to the shift interlock on the gear selector and the wiring is good. One strange thing, the shift interlock is not working. Meaning you can shift into gear without applying the brake. The solenoid is good, applied 12 v and it locks the gear selector. But there is no signal to energize the solenoid. Brake lights do work, but could the brake light switch be bad? Also I took a snap shot of the conditions that set the error code. It says that the actuator supply voltage was only 9v. That doesn't sound right to me.

  8. #6
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16
    Has anyone had experience replacing the mechatronic and valve body?

  9. #7
    FRESHMAN ROVER maximus5403's Avatar
    Join Date
    September 3rd, 2013
    Location
    Florida
    Posts
    24

    Re: 2008 transmission limited gear error message

    You don't want to replace the mechatronic as it requires coding to the car and dealers are a pain about it. You can get a new valve body and switch the black mechatronic portion over to it. You could get your current valve body refurbished if it's causing an issue. I believe it's rare for the electronic portion to go bad (other than the solenoids).
    2012 Range Rover Supercharged 5.0
    2007 Range Rover Supercharged 4.2

  10. #8
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16
    That's the thing, it is bad according the the diagnostics code. I have a tool to program.

  11. #9
    FRESHMAN ROVER
    Join Date
    October 7th, 2016
    Location
    Washington, DC
    Posts
    9

    Re: 2008 transmission limited gear error message

    I would change the brake light switch and the brake light bulbs. I just had the same codes on the dash +HDC fault. Swapped my battery because it was dead (AAA) and it cranked up just fine. The next morning it struggled to start, sounded bogged down, but managed to get it to start. 4 hrs of diagnosis at the dealerand it ended up being a coolant temp sensor (1/15 codes from the scanner). I had recently got this swapped most likely because of age and my mechanic didn't replace with an OEM coolant temp sensor. From everything I read brake light switch, bulbs (Use OEM only), abs sensor, bad battery, coolant sensor (personal experience), water in the floor/kick panel/ look for corroded wires, loose grounds, water in the computer module behind the battery (forget which one that is) can all cause these codes. I had just replaced my transmission and the sensor about a month ago but I dit not have any leaks. I am picking my truck up tomorrow. Giving the dealer a call in the am to see if it cranks up fine, Ill update if it changes. Hope this helps.

  12. #10
    FRESHMAN ROVER
    Join Date
    September 25th, 2018
    Location
    Lake Havasu City, Arizona
    Posts
    16
    Thanks. Let us know what they find. Brake lights all work fine. Not sure if the brake light switch can have a failure that can cause this issue but still have working brake lights

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. P0705 error message and transmission failsafe at START ONLY
    By NairoDar in forum Range Rover Mark III / L322
    Replies: 17
    Last Post: October 12th, 2016, 06:49 PM
  2. transmission fault limited gears only 2008 range rover SPG
    By edemkofi in forum Range Rover Sport / L320
    Replies: 1
    Last Post: July 23rd, 2016, 08:39 AM
  3. How "Limited" is the Limited Edition GT?
    By nosebreaker in forum Range Rover Sport / L320
    Replies: 9
    Last Post: October 17th, 2013, 11:41 PM
  4. Tdsc or hdsc error message transmission error
    By Lone Rangerover in forum Range Rover Sport / L320
    Replies: 4
    Last Post: November 20th, 2009, 08:04 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0