Electrical & Power Problem
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
Results 1 to 5 of 5

Thread: Electrical & Power Problem

  1. #1
    SOPHOMORE ROVER
    Join Date
    May 19th, 2014
    Location
    Long Island, NY
    Posts
    363

    Angry Electrical & Power Problem

    I took the 2006 4.4L to pick up some things at the supermarket on this wet rainy morning. Went inside and came back out 15 minutes later and nothing when I turned the key. In fact the ignition switch didn’t want to turn at first.

    I took the jumper pack out of the back and the voltmeter read 12.5 volts. I thought that odd since she seemed dead. Go to start the car and nothing at first (can’t turn key) and then she started, all within 5 seconds. She idles/runs fine while I packed up the jumper pack.

    I put her into gear and she won’t go above 1500 RPM, it’s as if there’s some types of limiter because she isn’t straining or misfiring. Forward and reverse gears are the same.

    I limped home (2 miles) at 5-10 MPH but couldn’t make it up my inclined driveway to the garage, so I parked her in the pull off area by the road.

    I turned her off and now she’s dead again, no lights, nothing.

    I suspect it’s an electrical problem, but what puzzles me is the fact that once she was running it would not rev above 1500 RPMs.

    Has anyone seen these symptoms before?

    The vehicles has 165,000 miles and was running great before this. The battery is one year old (I’ll test it anyway).
    No check engine light when she was running. I’ll try to read for codes if I can get juice to flow again and turn the ignition switch on.

    Very strange... and of course it’s raining and she’s 300 feet from my garage, and I’m going in for knee surgery in 18 hours.
    2006 Range Rover HSE 4.4L AJ41
    2004 Range Rover HSE 4.4L M62
    Quick reply to this message Reply  

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FORUM MODERATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Kloshe Lodge, Shelter Bay, Washington
    Posts
    27,609

    Re: Electrical & Power Problem

    run through the electrical testing sticky. Has it been under freezing at night? Your battery may be only a year old but a corroded cable can ruin a battery in short order. So can a weak alternator, but you won' be able to test that until you are up and running.
    When dealing with yourself, act with your brain
    When dealing others, act with your heart.
    Quick reply to this message Reply  

  4. #3
    SOPHOMORE ROVER
    Join Date
    May 19th, 2014
    Location
    Long Island, NY
    Posts
    363

    Re: Electrical & Power Problem

    Thank you for the suggestions RRToadHall, that was my plan. While I was having a bite to eat and posting this thread I was thinking, why did the battery pack make a difference if the battery were good? I thought maybe a terminal connection were loose and clamping the jumper wire on moved it slightly.

    Well, I went out with a 10mm socket and wrench and found both terminals could swivel slightly. I tightened them up and voila, she works fine.

    I guess loose terminals didn’t allow the systems to draw enough current. Even though the voltage across the terminals was adequate, that does not ensure that the amperage draw is sufficient.

    I still would like to uderstand why I couldn’t get more than 1500 RPMs. It must be the ECU not functioning correctly..... who knows????
    2006 Range Rover HSE 4.4L AJ41
    2004 Range Rover HSE 4.4L M62
    Quick reply to this message Reply  

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER
    Join Date
    October 30th, 2013
    Location
    Qatar
    Posts
    12
    Hi sounds like short in the batt, the batt is a critical part in today's vehicles
    Dependingbon the year of the vehicle the battery charge system may also has a electronic module so when you fit new batt you will need to reset this otherwise if will try to charge the battery as the previous one and will degrade new batt
    Quick reply to this message Reply  

  7. #5
    FORUM MODERATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Kloshe Lodge, Shelter Bay, Washington
    Posts
    27,609

    Re: Electrical & Power Problem

    Qatar, the OP's two rigs are properly listed in his signature. Is yours?

    I don't believe there are any battery modules to reset on any RR that has been in my shop. Some have an explosive positive terminal clamp that disconnects power if the SRS is triggered
    When dealing with yourself, act with your brain
    When dealing others, act with your heart.
    Quick reply to this message Reply  

Quick Reply Quick Reply

Register Now

Similar Threads

  1. BECM Corrosion - Power Board & Logic Board (Fuse 6, 7, & 17)
    By enbruchman in forum Range Rover Mark II / P38
    Replies: 8
    Last Post: March 1st, 2018, 01:24 PM
  2. Replies: 24
    Last Post: December 11th, 2014, 06:23 AM
  3. power/electrical problem
    By dubnation in forum Range Rover Mark II / P38
    Replies: 2
    Last Post: December 5th, 2013, 02:53 AM
  4. strange electrical problem. power steering/ locks and tailgate
    By coach J in forum Range Rover Mark III / L322
    Replies: 9
    Last Post: August 16th, 2013, 10:43 AM
  5. Electrical Troubleshooting Manual Question F22 & F9 & Left Door Outstation
    By enbruchman in forum Range Rover Mark II / P38
    Replies: 0
    Last Post: October 30th, 2012, 07:57 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0