Random Engine Issue
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
Results 1 to 3 of 3

Thread: Random Engine Issue

  1. #1
    FRESHMAN ROVER
    Join Date
    August 29th, 2017
    Location
    Tanzania
    Posts
    62

    Random Engine Issue


    Please watch the video, this happens randomly
    the first 11 seconds of the video is after I shut down the engine and then restarted it, then the problem went away
    after 11 seconds into the video is when the problem showed up, you can see the rev goes very low even reaching at 0 and the car is still running, when i press the accelerator pedal the rev goes to 0 instead of revving up when I let go of the accelerator it goes to idle, no check engine light, and this problem happens randomly
    Quick reply to this message Reply  

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    May 26th, 2016
    Location
    Washington, DC
    Posts
    68

    Re: Random Engine Issue

    Seems to be running okay. It's just not indicating correctly. Without breaking out my copy of the RAVE, not sure what sensor drives the tach. Probably a crankshaft position sensor which could be failing. I'd research that in the manual.

    Sent from my SM-G960U using Tapatalk
    Quick reply to this message Reply  

  4. #3
    FRESHMAN ROVER
    Join Date
    August 29th, 2017
    Location
    Tanzania
    Posts
    62

    Re: Random Engine Issue

    it is a 2004 range rover vogue, 4.4 V8 with 200,000km
    Quick reply to this message Reply  

Quick Reply Quick Reply

Register Now

Similar Threads

  1. Random steering wheel heater issue
    By dudeonthenet in forum Range Rover Sport II / L494
    Replies: 8
    Last Post: June 20th, 2014, 03:32 PM
  2. I've got a very random temp spike issue
    By e30jrosso in forum Range Rover Mark II / P38
    Replies: 12
    Last Post: October 23rd, 2013, 08:09 AM
  3. '93 LWB 4.2L, chronic, random engine shut-down and diagnostic
    By brider in forum Range Rover Classic
    Replies: 3
    Last Post: September 5th, 2013, 07:30 AM
  4. Amber check engine light on at random.
    By L322Pilot in forum Range Rover Mark III / L322
    Replies: 3
    Last Post: January 20th, 2011, 02:33 PM
  5. random unplugged 2 wire connector in engine bay
    By Roverrated in forum Range Rover Mark II / P38
    Replies: 7
    Last Post: September 27th, 2007, 03:09 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0