P400e issues
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 13 of 13

Thread: P400e issues

  1. #1
    FRESHMAN ROVER
    Join Date
    March 2nd, 2016
    Location
    Brussels
    Posts
    101

    P400e issues

    I have 2 p400e RR Sports.

    I just wanted to share with you the issues because clearly they are common to the two vehicles

    Both are 2019 MY with same HSE dynamic trim, the only differences between the two cars are the colours, interior trim options and wheels

    Vehicle 1:
    Glitch infotainment, lags, black screen, apple car play dodgy
    Failure of all systems related to headlights e.g. emergency autonomous braking, traffic sign recognition, adaptive headlights etc. Solved after two dealer trips and two software updates
    Engine problem yellow light, - was a gas particulate filter problem, lack of regeneration even though it had been doing regeneration cycles. Maybe a hybrid issue in that the engine is barely used in city driving?

    Vehicle 2
    Complete engine power loss on the motorway, complete black screens everywhere. Engine would not restart. Solved after car was closed and locked for 20 mins and the engineer restarted it and everything worked fine. Dealer couldn't figure it out.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    Premium Member
    Join Date
    December 29th, 2013
    Location
    Windham, New Hampshire
    Posts
    1,677

    Re: P400e issues

    Thank you for testing them extensively before they arrive in the US.
    Or, more seriously, that sounds bad.
    2018 Range Rover SCV8
    2017 Range Rover Sport SCV8 Dynamic
    2017 Range Rover Evoque HSE

  4. #3
    GPS
    GPS is offline
    FRESHMAN ROVER
    Join Date
    May 16th, 2016
    Location
    Montego By- Jamaica
    Posts
    61

    Re: P400e issues

    Hi
    "was a gas particulate filter problem, lack of regeneration even though it had been doing regeneration cycles" but this looks like you have a diesel engine, I thought the P400e has a 2L turbo gasoline...

    My friend have a RRS with the 2L (300Hp), same engine that your car should have and his car manual have no mention of "regeneration cycles"
    RRS 2015 SC Dynamic
    LR4 V8 5.0
    MB500R
    Audi A8 V8 4.2
    LR3 V8 4.4 Italy
    MB500SEL-1992 Italy
    Fiat500 1972 Italy

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER
    Join Date
    August 20th, 2012
    Location
    Cheltenham
    Posts
    5

    Re: P400e issues

    The new petrol models have GPF, I have one on a 2019 SVR and the GPF has made it sooo quiet

  7. #5
    FRESHMAN ROVER
    Join Date
    March 2nd, 2016
    Location
    Brussels
    Posts
    101

    Re: P400e issues

    In Europe, petrol (gas) engines also need a particulate filter, just like diesel engines. My theory is that because of the very occasional use of the petrol engine in city engine cycles, the filter never gets up to temperature to burn off the particulates. When it does get up to temperature e.g. in motorway driving, something is stopping the regeneration from happening properly.

  8. #6
    NEWBIE
    Join Date
    April 28th, 2019
    Posts
    2
    Hi,

    I am a new RR Hybrid owner. 2 times I charged the car and confused a bit with the results:

    In the first charge, It took 4.5 hours for 100% charge and showed me 31 miles with 100% and unfortunately I did only 7.2 miles with 100% charge.

    Today I charged the car with an other charge point , It took again 4.5 hours to charge completely and it showed 25 miles max with 100% charge.

    Did anyone test the charge more than twice and if pos could you share the results ( at least the averages) ? I feel, I need to adjust my expectation from EV and Hybrid, or I make a mistake while charging or using the car or my car has a problem with EV and/or Hybrid.

  9. #7
    FRESHMAN ROVER
    Join Date
    June 14th, 2006
    Location
    Austin, Texas
    Posts
    22

    Re: P400e issues

    I'm seriously considering dropping my 2020 RR PHEV pre-order and just ordering a Model 3....too many issues with these vehicles.
    2016 Range Rover Diesel
    Fuji White / Almond Interior

  10. #8
    FRESHMAN ROVER
    Join Date
    March 1st, 2014
    Location
    Munich
    Posts
    148
    My P400e is faultless (drivetrain) and I only had a regular Service since new from August 2018, arrived around 23.000 mls., now.

  11. #9
    FRESHMAN ROVER
    Join Date
    March 2nd, 2016
    Location
    Brussels
    Posts
    101

    Re: P400e issues

    I keep getting check engine yellow warning lights, the dealership keeps upgrading control modules, whatever this means... Never seems to work as the light comes on again after refueling, usually after a long journey of 400km or so.

  12. #10
    Premium Member
    Join Date
    December 29th, 2013
    Location
    Windham, New Hampshire
    Posts
    1,677

    Re: P400e issues

    you might just be getting bad gas - try to fill it up elsewhere.
    2018 Range Rover SCV8
    2017 Range Rover Sport SCV8 Dynamic
    2017 Range Rover Evoque HSE

  13. #11
    FRESHMAN ROVER
    Join Date
    March 2nd, 2016
    Location
    Brussels
    Posts
    101

    Re: P400e issues

    it was at two different gas stations, different companies in different parts of the country. Only happens in the UK, never in Belgium. strange...

  14. #12
    FRESHMAN ROVER
    Join Date
    October 27th, 2018
    Posts
    11
    You need to go back to the dealer. I do average of 40 to 45 km on it (hybrid not just ev alone). My 100% is sometimes 43 to 50km. This depends on the previous charge. It will be an estimate. Never 7 miles though! From 0 to full charge it takes 7 hrs so you might be using a fast charger right?

  15. #13
    FRESHMAN ROVER
    Join Date
    October 27th, 2018
    Posts
    11
    Hi
    Do you wver hear a owcking noise from the battery at the back when you switch off the engine after a trip? Its a bit odd. Anyone kbows what this is?
    Thanks

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Similar Threads

  1. Does P400E has 'combined' drive mode?
    By godza in forum Range Rover Sport II / L494
    Replies: 21
    Last Post: July 6th, 2019, 05:21 AM
  2. P400e delivery
    By dekoene in forum Range Rover Sport II / L494
    Replies: 204
    Last Post: March 4th, 2019, 05:36 PM
  3. P400e charging infrastructure on 32A
    By dekoene in forum Range Rover Sport II / L494
    Replies: 4
    Last Post: August 10th, 2018, 07:37 AM
  4. Anyone in USA order P400e?
    By rockybird in forum Range Rover Sport II / L494
    Replies: 4
    Last Post: July 29th, 2018, 02:39 PM
  5. Anyone order the P400e in US yet?
    By rockybird in forum Range Rover Sport II / L494
    Replies: 6
    Last Post: July 13th, 2018, 02:33 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0