Alternate Replacement Head Units for older L405's - Page 5
  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Page 5 of 8 FirstFirst 1 2 3 4 5 6 7 8 LastLast
Results 61 to 75 of 113

Thread: Alternate Replacement Head Units for older L405's

  1. #61
    SOPHOMORE ROVER
    Join Date
    July 30th, 2007
    Location
    Chicago, Illinois
    Posts
    419

    Re: Alternate Replacement Head Units for older L405's

    Wait,

    I really appreciate this thread and hope you resolve the issue soon. This will sound crazy, but you did disconnect the battery before beginning the project, right? Just trying to think of why the OEM unit doesn't work.

    Steve

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #62
    FRESHMAN ROVER BigladUK's Avatar
    Join Date
    January 28th, 2019
    Location
    UK
    Posts
    42

    Re: Alternate Replacement Head Units for older L405's

    I don't think he did, also the video thats been posted ( maybe by me from YouTube ) seems to look like they don't do the install with the battery disconnected either although I was thinking the same as you , should it be disconnected while doing the install..maybe this has caused the issue ?

    Si

  4. #63
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    Quote Originally Posted by BigladUK View Post
    Something thats been puzzling me since we began this adventure is the whole capacitive vs resistive situation, I know mine is capacitive ( Dual View as it's an AB ) so are you sure yours is Resistive ?

    Not sure if the wrong screen type might break the Infotainment brain.

    My understanding of the difference is that capacitive works with a finger and resistive works with a finger nail, would your original screen work with a finger nail ?


    BTW mine didn't have a sticker on the outside of the box with details of which version it is like yours did. I'm hoping to get mine attempted to be installed at the weekend.

    Si
    Yes, I made sure that my original screen was resistive touch and single view...it can be touched with a fingernail or pen. I also emailed the seller pics of the original screen before the order was processed. The strange thing is that my new android screen was showing the original menu screen when I first plugged it all in and everything seemed to work fine. I then unplugged a few of the connectors on the harness to sort the wiring for a cleaner install and after I plugged it all back in, the menu screen was showing no signal and there was no sound.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #64
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    Quote Originally Posted by stemikel View Post
    Wait,

    I really appreciate this thread and hope you resolve the issue soon. This will sound crazy, but you did disconnect the battery before beginning the project, right? Just trying to think of why the OEM unit doesn't work.

    Steve
    No, I didn't disconnect the battery. The installation video didn't show them disconnecting the battery either. I really wish the seller would make an owners/installation manual for those if us here in the US that purchase this unit...that would be greatly appreciated.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  7. #65
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    Here's a pic of my finished install...I just have to pull it apart again to install the new SatNav DVD unit when it arrives on Wednesday...
    Attached Thumbnails Attached Thumbnails Alternate Replacement Head Units for older L405's-img_2466.jpg  
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  8. #66
    FRESHMAN ROVER BigladUK's Avatar
    Join Date
    January 28th, 2019
    Location
    UK
    Posts
    42
    It does look awesome, can’t wait to get mine installed.

    Have you figured out what the external speaker is for ?
    Have you managed to install any apps like Waze or Apple Music ?
    Where have you put the microphone ?
    Where have you put the GPS receiver ?

    Hope your replacement brain all goes ok 🤞

    Si

  9. #67
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    Quote Originally Posted by BigladUK View Post
    It does look awesome, can’t wait to get mine installed.

    Have you figured out what the external speaker is for ?
    Have you managed to install any apps like Waze or Apple Music ?
    Where have you put the microphone ?
    Where have you put the GPS receiver ?

    Hope your replacement brain all goes ok 🤞

    Si
    Here's the video that I followed for the install...https://www.youtube.com/watch?v=HiBQ...ature=youtu.be

    I haven't figured out what the external speaker is for but I have it connected and I placed it in the same place they did in the video.
    I haven't installed any apps yet and I'm not sure if I will need to because the Apple CarPlay does all that I need it to do...I can use Waze or Apple music with CarPlay. I also installed the microphone right next to the steering wheel like they did in the video and it's almost completely hidden.
    As far as the GPS antenna, I plugged it in and just placed it behind the screen because I probably won't be needing it. Andy told me that the GPS antenna is for the Sygic offline map that he already installed on the android. I don't think I will ever be using the Sygic map either but it's there if I ever decide to play around with it. There's also a wifi antenna included that I installed just under the drivers side dash and it's almost completely hidden...Andy told me that the wifi antenna is to help the wifi signal for hotspot to your phone. But once again, I probably won't use hotspot either because the Apple Carplay seems to do all that I need it to do. In the meantime, I'm looking forward to you getting yours installed and share your opinion on the unit.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  10. #68
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    update...well guys, the new DVD/SatNav unit arrived in the mail today and I got it installed. However, I'm still not getting a signal for the original menu screen, no sound output, no blind spot monitoring, no reverse traffic detection and no signal on reverse camera. I guess the DVD/SatNav unit wasn't the problem after all...but what are the chances the new unit is bad as well. I don't know what else to do at this point besides take it to the dealer for diagnostic but I am going to hate to have to pay for that, especially if it's something simple that I'm overlooking.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  11. #69
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    I just called the service manager at Land Rover Rancho Mirage and explained the issue to him. He told me that it sounds like it could be a software communication issue but they would have to run diagnostic on the vehicle to confirm that. I'm scheduled to drop it off on Friday for the diagnostic.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  12. #70
    SOPHOMORE ROVER
    Join Date
    January 29th, 2012
    Location
    Los Angeles, CA
    Posts
    370

    Re: Alternate Replacement Head Units for older L405's

    It's the new Chinese head unit. I'm bummed that you have to go to dealer to confirm. A quick test is plug back everything in the old system and see if it works? If so then it's the new head unit
    2014 Dodge Viper GTS Stryker Green
    2013 Range Rover Fuji White Full Size Mark L405 HSE Vision Pack w/ all LWB & AutoB trim!

  13. #71
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    Quote Originally Posted by mark1107 View Post
    It's the new Chinese head unit. I'm bummed that you have to go to dealer to confirm. A quick test is plug back everything in the old system and see if it works? If so then it's the new head unit
    mark1107, I already tried reinstalling the old system but the problem still exist. The original screen doesn't even turn on at all with the old system installed now. Everything was working fine before I installed the android screen...actually, the android screen was working fine when I first plugged it in. However, I unplugged it to sort the wiring for a clean install but after I got it all sorted and tried turning it back on, that's when I got the no signal on the menu screen. I've been in contact with the seller and he has been very helpful. He wants me to send the unit back and he will refund the payment. I asked him to send another unit for me to try but he said that he would have to inspect the unit that I'm returning before sending another unit. He also said that he had other US customers that installed the unit with no problem. This android screen is really nice and I don't like the idea of returning it. I hope to sort out the problem and give it another try. Overall, I think it's worth the trouble. I have the old system back in now and looking at it just reminds me why I wanted the new screen to begin with.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  14. #72
    SOPHOMORE ROVER
    Join Date
    January 29th, 2012
    Location
    Los Angeles, CA
    Posts
    370

    Re: Alternate Replacement Head Units for older L405's

    Thank you for the update. Please keep us posted. Hopefully it’s just a software glitch or a fuse
    2014 Dodge Viper GTS Stryker Green
    2013 Range Rover Fuji White Full Size Mark L405 HSE Vision Pack w/ all LWB & AutoB trim!

  15. #73
    FRESHMAN ROVER BigladUK's Avatar
    Join Date
    January 28th, 2019
    Location
    UK
    Posts
    42

    Re: Alternate Replacement Head Units for older L405's

    I'm not an expert in this subject but I have a couple of thoughts

    Idea 1
    When you unplugged everything to tidy up the wires and then plugged it all back in, maybe you dislodged or damagaed a cable from the existing wiring harness ? Prevelent wiring would be power and fibre, I guess you could check the fibre's are working by seeing if they omit light ? And I guess you could check power with a muiltimeter ?
    Idea 2
    On the CAN BUS maybe you've locked out or caused an error to the Infotainment brain which needs maybe software reseting ( which the dealer could deffo sort for you ) or perhaps disconnecting the battery will perform a reset ?

    As the replacement device didn't resolve the problem and putting everything back in as was I would guess the problem is something specific to the car or the boards from the screen ( but as you can't even eject the CD and I assume can't hear the hard drive spin up when you give it power it's more likely in the infotainment brain I'd have thought )

    Si

  16. #74
    SOPHOMORE ROVER W84IT's Avatar
    Join Date
    June 29th, 2010
    Location
    Indio, CA
    Posts
    403

    Re: Alternate Replacement Head Units for older L405's

    Quote Originally Posted by BigladUK View Post
    I'm not an expert in this subject but I have a couple of thoughts

    Idea 1
    When you unplugged everything to tidy up the wires and then plugged it all back in, maybe you dislodged or damagaed a cable from the existing wiring harness ? Prevelent wiring would be power and fibre, I guess you could check the fibre's are working by seeing if they omit light ? And I guess you could check power with a muiltimeter ?
    Idea 2
    On the CAN BUS maybe you've locked out or caused an error to the Infotainment brain which needs maybe software reseting ( which the dealer could deffo sort for you ) or perhaps disconnecting the battery will perform a reset ?

    As the replacement device didn't resolve the problem and putting everything back in as was I would guess the problem is something specific to the car or the boards from the screen ( but as you can't even eject the CD and I assume can't hear the hard drive spin up when you give it power it's more likely in the infotainment brain I'd have thought )

    Si
    I do remember unplugging all the cables on the DVD/SatNav unit so that I could move it out of the way while I sorted all the other wiring cables. That's why I'm also thinking that I could have dislodged or damaged one of the existing cables...or maybe unplugging that unit made the software glitch. I've checked all the cables maybe 4-5 times but I can't see where there could be any damage to the plugs. I've also checked the fuses and the main plug for power and it's getting power. Whatever the problem is, there's all lot that's linked to it...

    Main Menu screen doesn't turn on or even show logo at startup
    Rear Seat Entertainment screens don't show logo at startup
    No Menu selection from steering wheel switches
    No Bluetooth connection
    No Sound/Volume
    No Signal from Reverse Camera when vehicle is in reverse
    Reverse Traffic Detection Not Available
    Blind Spot System Not Available

    Could this really be a software problem or maybe a module that's gone bad? I just hate to have to take it to the dealer but I don't know what else to do at this point. Also, I don't like the idea of the service guys removing parts or trim pieces from my vehicle to try to find the issue if they can't diagnose it with the diagnostic system.
    Ray

    Current:
    2013 Range Rover L405 HSE(Fuji White with Almond Interior)

    Previous:
    2010 Range Rover L322 HSE(Alaska White with Jet Interior)
    2005 Range Rover L322 HSE LUX(Zambezi Silver with Charcoal Interior)
    2005 Range Rover L322 HSE(Zambezi Silver with Charcoal Interior)
    2004 Range Rover L322 HSE(Adriatic Blue with Sand Interior)

  17. #75
    SOPHOMORE ROVER
    Join Date
    July 30th, 2007
    Location
    Chicago, Illinois
    Posts
    419

    Re: Alternate Replacement Head Units for older L405's

    Have you tried to disconnect the battery and do a hard reset? Are you able to read codes?

+ Reply to Thread
Page 5 of 8 FirstFirst 1 2 3 4 5 6 7 8 LastLast

Quick Reply Quick Reply

Register Now

Similar Threads

  1. Yellow relay, alternate source
    By bomana in forum Range Rover Mark II / P38
    Replies: 0
    Last Post: September 14th, 2012, 03:51 PM
  2. alternate PS pump 95 LWB - Chevy S10
    By Sapelo Rover in forum Range Rover Classic
    Replies: 0
    Last Post: July 12th, 2010, 08:42 PM
  3. Alternate Parts Source in Seattle - Autosport
    By bchriste in forum Range Rover Mark II / P38
    Replies: 1
    Last Post: October 26th, 2007, 10:32 AM
  4. Favorite Replacement Head Units
    By pvcmpd in forum Range Rover Mark II / P38
    Replies: 11
    Last Post: September 9th, 2006, 05:22 AM
  5. EASY WAY TO ADD AN IPOD TO CLARION HEAD UNITS!
    By 2000m5 in forum Range Rover Mark II / P38
    Replies: 7
    Last Post: January 20th, 2006, 09:04 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0