SERVICE REQUIRED message - ahead of its time for MY 10-11
NEWS
 

  1. Welcome to RangeRovers.net General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 5 of 5

Thread: SERVICE REQUIRED message - ahead of its time for MY 10-11

  1. #1
    FRESHMAN ROVER AwfAxis's Avatar
    Join Date
    October 27th, 2010
    Location
    Reno Nevada
    Posts
    247

    SERVICE REQUIRED message - ahead of its time for MY 10-11

    So I fire up the RRS today, and for the first time, I notice a "Service Required" message in the center display. There are no other error warnings, so I run a quick errand. Believing in the philosophy of RTFM, I do my research.

    Per RRS Handbook, this message comes on when; a) you have hit your 15k mile service interval, or b) 12 months have elapsed. So I'm at 8200 miles, and have only 9 months on the clock (since purchase).

    Checking the VIN information on TOPIx, it says the car was built end of July '10. This would equate to just over a year.

    I call my service guy up, and he says that the message is a mistake, and although the reset of the service date is done on customer delivery, many MY 10-11's are coming in with incorrect warnings. Says it must be a software glitch.

    Has anyone else had premature warnings? The message only appears for 2 seconds on start-up. I'm thinking the PDI was not done properly.

    2011 Range Rover Sport GT LE
    2012 Ford F-150 FX4 ECB (Yee-Haw)
    2010 Trek 6000 Series
    2010 New balance 993

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    August 26th, 2008
    Location
    Toronto, ON (Canada)
    Posts
    94

    Re: SERVICE REQUIRED message - ahead of its time for MY 10-1

    Ha! I had this too the other day! Haven't noticed it since, but I might just have missed the 2 second window to see it.
    My car is a MY2011 HSE of which I took delivery in October 2010, so we're not at 1yr yet and the mileage is only 13k kilometers!

    My service guy had nothing else to say than: "We'll look into that when you bring it in next"
    ----
    2007 RRS HSE LUX Black & Beige [NOW RETIRED]
    2006 Porsche Boxster S [SUMMER TOY]
    2011 RRS HSE LUX Stornoway & Black [DAILY DRIVER]

  4. #3
    FRESHMAN ROVER
    Join Date
    October 27th, 2010
    Posts
    12

    Re: SERVICE REQUIRED message - ahead of its time for MY 10-1

    I own a MY 2010 HSE Lux and also had this warning show up about 10 months and 10,000 miles into ownership. The dealer told me not to worry and ignore as long as no warning lights (orange not red) illuminate. I made an appointment at the 12 month (approx. 12,500 mi) and all was OK. I was told a "simple" reset was all that was necessary on top of the first required maintence.

  5. #4
    FRESHMAN ROVER
    Join Date
    November 19th, 2011
    Location
    Boston
    Posts
    36

    Re: SERVICE REQUIRED message - ahead of its time for MY 10-11

    I just had this happen too on my '11. I got it in Nov last year, and there's only 10,500 miles right now, yet that message is present right now. Obviously, it seems my car was built around August of last year, hence the 12 month timeframe, and as you guys said, the dealers didn't reset them correctly or it's a bug. Makes no diff, called dealer told them about it and my plan to ignore it and just come in at 15k miles for my free maintenance
    2011 RRS HSE - Fuji White/Arabica/Anigre - LUX - Vision Assist - LOGIC7 - Full int/ext bulbs LED conversion

  6. #5
    NEWBIE
    Join Date
    August 1st, 2012
    Location
    Abington, MA
    Posts
    2

    Re: SERVICE REQUIRED message - ahead of its time for MY 10-11

    There's no software glitch. The interval reset is a huge pain for technicians if they don't have a plug in OBDII reset tool. The clock starts once it's taken out of transport mode at PDI. If it was built in July it may not have had it's PDI until August. They should be able to just reset it for you. Make sure you don't go beyond 14 months before claiming free service or Land Rover won't pay!

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Similar Threads

  1. Service-time !
    By Shogo in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: May 26th, 2011, 11:36 PM
  2. Service 19 Message?
    By bogart101 in forum Range Rover Sport / L320
    Replies: 6
    Last Post: June 16th, 2009, 09:41 AM
  3. message center gone after service
    By Luetic in forum Range Rover Mark III / L322
    Replies: 6
    Last Post: May 4th, 2009, 04:25 AM
  4. Service indicator problem - help required please.
    By Manks in forum Range Rover Mark III / L322
    Replies: 4
    Last Post: September 15th, 2008, 01:09 AM
  5. Service garage required near Reading UK
    By Othillo in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: January 9th, 2008, 02:39 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2