Heater/AC issue
NEWS
 

  1. Welcome to RangeRovers.net General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 13 of 13

Thread: Heater/AC issue

  1. #1
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Heater/AC issue

    Hi

    I've got an 89 RRC and the blower only works on the AC setting. I get all 3 speeds. However when the selector is on any of the other settings (recirc, fresh air, etc), the blower does not work at all. I only hear a slight 'whirring' noise that ramps up a little with each speed, but no air comes through the vents.

    I'm assuming that the blower motor works, since it works great on AC. I'm also assuming that the resistor is working since I do get all 3 speeds.

    Therefore I'm guessing that the selector switch is bad? Is that the right assumption, or is there anything else I am missing? I'm having trouble locating that switch since I don't know the exact name of it. I only find the blower switch at stores, which I don't believe I need.

    Thanks in advance.

  2. Remove Advertisements
    RangeRovers.net
    Advertisements
     

  3. #2
    SOPHOMORE ROVER
    Join Date
    February 6th, 2009
    Location
    Penn Hills, Pennsylvania
    Posts
    342

    Re: Heater/AC issue

    there are seperate motors for ac and heater. ac motors are under dash on pass side , heater is inside dash behind heater controls. go to atlantic british homepage tech info blower motor for pics of motor and replacement inst.

  4. #3
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Re: Heater/AC issue

    I didn't see any separate blower motors for AC and heater. And isn't the heater core on the pass side behind the dash?

  5. #4
    SITE ADMINISTRATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Maltby, WA USA
    Posts
    15,895

    Re: Heater/AC issue

    Heater core is dead center of the rig behind the climate controls. See the pages on Atlantic British referenced above.
    My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention.

  6. #5
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Re: Heater/AC issue

    Thanks for responding, everyone.
    Ok, so I looked at this tutorial: http://www.roverparts.com/Instruction%20Photos/Instructions-HeaterBMK-8844.pdf

    P
    age 9 shoes the heater core on the passenger side. Page 19 shows the blower in the middle of the dash. Again, only one blower is shown for this entire tutorial, so I'm a little confused. I'm really hoping I don't have to do that much work though to fix the heater! :-O

  7. #6
    SITE ADMINISTRATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Maltby, WA USA
    Posts
    15,895

    Re: Heater/AC issue

    Now I am confused as well! I have a feeling i have P38 on the brain and am mixing up my various projects over the years.
    My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention.

  8. #7
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Re: Heater/AC issue

    LOL, Ok, now that makes a little sense. I did a quick search on Atlantic British and I see both a blower motor, and a blower motor right-side for the P38.

    So, is it safe to say the RRC (1989) has just one blower motor? And, does that mean mine works, and I just need to replace the switch? (the blower works, but only when selected for AC) Or....?

  9. #8
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Re: Heater/AC issue

    BUMP
    (it's cold!)

  10. #9
    SITE ADMINISTRATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Maltby, WA USA
    Posts
    15,895

    Re: Heater/AC issue

    If your cold use the AC on hot since the fan works in that mode.
    My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention.

  11. #10
    SOPHOMORE ROVER
    Join Date
    February 6th, 2009
    Location
    Penn Hills, Pennsylvania
    Posts
    342

    Re: Heater/AC issue

    its a lot of work but first test resistor , unlikely but this may be your problem but is going to be replaced anyway so it doesnt hurt to check.

  12. #11
    NEWBIE
    Join Date
    December 26th, 2011
    Location
    salt lake city
    Posts
    1

    Re: Heater/AC issue

    I found this out the other day. Your dash vents will never blow hot air. Only defrost and foot will blow heat. Not really sure if this is what you were talking about but i found it interesting.

  13. #12
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Re: Heater/AC issue

    Ah, ok. Then that makes a LOT more sense and definitely narrows the troubleshooting. Thanks!

    I will definitely look at the resister first thing. If not that, could it be the blower then?

  14. #13
    FRESHMAN ROVER
    Join Date
    December 12th, 2011
    Location
    United States
    Posts
    8

    Re: Heater/AC issue

    Update: There is a dull clicking noise that comes from somewhere in the dash, I believe. This only happens when I turn the wheel to the left (while moving) and with the fan turned on to any speed. At first I thought it was a steering issue until I realized it does not occur when the fan speed it off. Any ideas what that noise is? It is erratic, but gets faster the faster I'm moving. It doesn't appear to come from under the hood or underneath.

    I'm supposed to go to Tahoe this weekend for new year's eve, but it's going to suck without a heater.

Similar Threads

  1. Blend flaps / Heater Box / Heater core /Dash -Lots of photos
    By lui2001 in forum Range Rover Mark II / P38
    Replies: 11
    Last Post: December 11th, 2013, 05:53 AM
  2. Tailgate issue, and pesky passenger door issue...
    By CHRISDANIELS33 in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: May 24th, 2010, 12:06 PM
  3. Different heater issue, one speed then huge draw?
    By GrFa in forum Range Rover Classic
    Replies: 4
    Last Post: January 14th, 2010, 06:59 AM
  4. Ignition issue or on board computer issue
    By cackatron in forum Range Rover Mark III / L322
    Replies: 13
    Last Post: October 21st, 2009, 07:00 AM
  5. Heater core O-rings. Heater pipe misalignment? No. read on.
    By Brett San Diego in forum Range Rover Mark II / P38
    Replies: 10
    Last Post: June 24th, 2008, 08:31 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2