Brake pump not working
NEWS
 

  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 6 of 6

Thread: Brake pump not working

  1. #1
    Premium Member crazyguy's Avatar
    Join Date
    October 28th, 2013
    Location
    Palm Beach, FL
    Posts
    309

    Brake pump not working

    Hello all,
    My brake pump has stopped working. I've checked the relays and they're working, and I appear to have 12v at the pump. When I turn the key I get nothing. Unfortunately the lady was driving the truck when it appears to have failed so I don't know what exactly happened. She didn't notice. Any help would be greatly appreciated. Brakes and pump worked great before with only a very sporadic odd sound out of the pump (less than once a month and only 3 times ever). I'd much prefer to not have to purchase a new pump. Is it serviceable?
    thanks!
    1990 RRC. 4.2 wearing green.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    FRESHMAN ROVER
    Join Date
    July 13th, 2008
    Location
    New York, USA
    Posts
    214

    Re: Brake pump not working

    Technically, the pump is rebuildable (http://www.rangerovers.net/repairdet....html#pumpdiag)

    IMO, it's simpler to find a used one elsewhere and installing it real quick. All year classics have the same pump but the connector might differ from years. Super simple to splice the correct connector in and be on your way again.
    1990 Range Rover - http://www.defendersource.com/forum/...irs-60356.html
    1995 Range Rover LWB - daily driver

  4. #3
    Premium Member crazyguy's Avatar
    Join Date
    October 28th, 2013
    Location
    Palm Beach, FL
    Posts
    309

    Re: Brake pump not working

    good advice. now to find a replacement!
    1990 RRC. 4.2 wearing green.

  5. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  6. #4
    FRESHMAN ROVER
    Join Date
    October 8th, 2015
    Location
    West Virginia
    Posts
    18

    Re: Brake pump not working

    I just had this happen. I tested everything like you did and decided to replace the relay anyhow before shelling out the cash. It worked and couldn't believe it. It might be worth a shot.
    1995 RRC LWB

  7. #5
    SITE ADMINISTRATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Kloshe Cottage, WA
    Posts
    22,913

    Re: Brake pump not working

    Since he had 12v at the pump connector then his relay was working properly.
    I've learned so much from my mistakes,
    I am thinking about making a few more.

  8. #6
    Premium Member crazyguy's Avatar
    Join Date
    October 28th, 2013
    Location
    Palm Beach, FL
    Posts
    309

    Re: Brake pump not working

    Quote Originally Posted by RRToadHall View Post
    Since he had 12v at the pump connector then his relay was working properly.
    yep, relays are working. bummer too, since that's the easy fix.
    1990 RRC. 4.2 wearing green.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Similar Threads

  1. Abs pump working in delay
    By noamh23 in forum Range Rover Mark II / P38
    Replies: 6
    Last Post: September 14th, 2016, 11:36 AM
  2. Quick fix to air up the tank without a working pump?
    By kingsly in forum Range Rover Mark II / P38
    Replies: 6
    Last Post: June 21st, 2016, 01:34 AM
  3. Can the brake switch be bad even if the brake lights are working?
    By Angelo1 in forum Range Rover Sport / L320
    Replies: 19
    Last Post: July 3rd, 2014, 10:25 PM
  4. 1989 rrc Fuel pump not working while cranking NO START
    By 1962siia88 in forum Range Rover Classic
    Replies: 1
    Last Post: January 10th, 2013, 08:35 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2