Fuel Gauge stopped working
NEWS
 

  1. Welcome to RangeRovers.net General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20

Thread: Fuel Gauge stopped working

  1. #1
    SOPHOMORE ROVER
    Join Date
    September 16th, 2006
    Location
    South Wales U.K.
    Posts
    459

    Fuel Gauge stopped working

    new problem this week the fuel gauge has stopped working, the needle is sat on empty with the warning light on, there's at least half a tank of petrol in it. Luckily I run on LPG but the Rangie has to start on petrol so it'd be nice to have the gauge working again.

    On occassion I have seen "Fuel Gauge Fault" in the message centre and sometimes when you switch on the fuel gauge shows half a tank but soon the needle drops to empty but only seen

    Checked the fuse and relay for the fuel pump they're ok, is it the sender unit in the tank or more likely a dodgy earth connection somewhere?
    South Wales Area Rep
    Range Rover Register
    www.rrr.co.uk
    95 Range Rover 4.6 HSE PowerFlow Stainless Exhaust...nice meaty V8 Rumble.

  2. Remove Advertisements
    Range Rovers Forum
    Advertisements
     

  3. #2
    SOPHOMORE ROVER
    Join Date
    October 16th, 2008
    Location
    Lincolnshire, UK
    Posts
    454

    Re: Fuel Gauge stopped working

    It's going to be faulty sender, loose connection above the fuel tank to the pump / sender or contaminents on the sender.

    The fuel gauge shares the earth with other gauges so doubt if it's that.

    I had this recently, bought new sender (40 ish), popped the back end on car ramps and dropped the tank.
    when i disconnected the multiplug above the tank it was too easy. They clip together and this time it just slid apart.
    Took the old sender out and tested with a multimeter (checking resistance) to find it did just the same as a new one.

    Put it all together again making sure the multiplug was fully connected and all works as it should.

    The whole job took approx 3 hrs including cups of tea and checking the sender.
    The tank was approx 1/2 full when i did mine. I used ratchet straps around the chassis to lower the tank. It could be done without them and with just a jack and a second pair of hands.

  4. #3
    FRESHMAN ROVER
    Join Date
    August 7th, 2006
    Location
    Perth, Western Australia
    Posts
    148

    Re: Fuel Gauge stopped working

    Sounds like it might be the tracks on the sender, pretty hard for the wiring to come loose. Another cause may be the the fuel float itself has soaked up some fuel and has basically sunk.. Doesn't matter what is is though, the tank has to come out..
    2002 Ford Series III AU XR8 Falcon
    1996 HSE Range Rover
    2006 Kawasaki ZX-14
    2005 Aprilia SR50 Factory Scooter
    1976 Leyland Mini Clubman S

  5. #4
    SOPHOMORE ROVER
    Join Date
    September 16th, 2006
    Location
    South Wales U.K.
    Posts
    459

    Re: Fuel Gauge stopped working

    Cheers guys sounds like a job for a sunny afternoon.

    Keith, where did you get your sender for 40? Does it seperate from the fuel pump then and not a combined sealed unit?
    South Wales Area Rep
    Range Rover Register
    www.rrr.co.uk
    95 Range Rover 4.6 HSE PowerFlow Stainless Exhaust...nice meaty V8 Rumble.

  6. #5
    SOPHOMORE ROVER
    Join Date
    October 16th, 2008
    Location
    Lincolnshire, UK
    Posts
    454

    Re: Fuel Gauge stopped working

    it comes seperate, Genuine p.No WGI100000 http://www.rimmerbros.co.uk/Item--i-WGI100000 36.45 plus del
    includes sender, float etc.

    Held in by 1 philips screw and 2 spade connectors

  7. #6
    LIFETIME CONTRIBUTOR
    Join Date
    June 14th, 2004
    Location
    Emu Plains, NSW, Australia
    Posts
    5,304

    Re: Fuel Gauge stopped working

    Mine hasn't worked for about 2 years. I replaced the pump and I think the aftermarket pump has a problem. I cut a hole through the floor and plugged in the old pump and the fuel gauge worked.

    I'll enlarge the hole and remove the pump from inside the car. My tank is a 155 litre aftermarket long range tank and is steel so I don't really want to drop the tank out.

    There is a page on the main site http://www.rangerovers.net/repairdetails/fuelpump4.html about cutting a hole in the floor but unfortunately the writer hadn't measured the distances from a couple of reference points to the centre of the pump so that we could accurately determine exactly where to cut the hole.

    I could give my measurements but I don't know if they are the same for a standard fuel tank.
    Ron Beckett
    1995 Range Rover HSE 4.6 V8 auto
    2007 Yamaha XJR1300
    2006 Suzuki DL650 V-Strom

    RIP Bucko (1979-2008 - Riding on forever)
    http://p38arover.com/lee_pix/bike_caricature-avatar.jpg

  8. #7
    SOPHOMORE ROVER
    Join Date
    September 16th, 2006
    Location
    South Wales U.K.
    Posts
    459

    Re: Fuel Gauge stopped working

    Thanks both I'll look into that, I'll go for a genuine one rather than aftermarket

    Ron, don't fancy cutting a hole in the floor to be honest I'll get the car up in the air and drop the tank from below, it may just be an iffy connection ontop of the tank but I'll get a sender just in case.

    Cheers for help guys.
    South Wales Area Rep
    Range Rover Register
    www.rrr.co.uk
    95 Range Rover 4.6 HSE PowerFlow Stainless Exhaust...nice meaty V8 Rumble.

  9. #8
    SOPHOMORE ROVER
    Join Date
    February 15th, 2009
    Location
    Cape Town
    Posts
    481

    Re: Fuel Gauge stopped working

    That idea of ratchet straps from the chassis I like; I had to drop mine for the in tank pump and it's great fun balancing it on the jack.
    I also struggled to get the filler neck in and out ; high suspension setting helps then leave a door open of pull the relay.

    Last tip; get a tin of paint. The 'cradle' that holds the tank can really collect salt and cause corrosion; first thing as you get it off clean it and give it a coat of paint - what harm can it do?
    P38A DHSE shiped UK to SA, very rare in SA!

  10. #9
    zem
    zem is offline
    FRESHMAN ROVER
    Join Date
    May 22nd, 2005
    Location
    Melbourne, Australia
    Posts
    136

    Re: Fuel Gauge stopped working

    I had the same 'FUEL GAUGE FAULT' message and needle sitting on empty with orange light on. The sender from the tank was faulty - once fixed/ replaced it worked fine....until recently.
    Now my same mechanic is telling me that it is a BeCM fault, not tank related. I am suspicious that he doesn't want to drop the tank again and instead charge me for a new BeCM. Your thoughts appreciated.
    1995 4.6 HSE :: 290,000km **New motor @ 280k **
    2.5" sports exhaust (head turning note
    Rhino alloy rack, Dual batteries,Toyo ATR's
    Tartarini injected LPG (72Lt donut)
    Camper Trailer with tinnie on roof
    2004 Yamaha WRF250

  11. #10
    SOPHOMORE ROVER
    Join Date
    October 16th, 2008
    Location
    Lincolnshire, UK
    Posts
    454

    Re: Fuel Gauge stopped working

    Would doubt it's the becm.
    Call his bluff, get him to fit the becm while your there, if it does not work you get the becm for free.

  12. #11
    zem
    zem is offline
    FRESHMAN ROVER
    Join Date
    May 22nd, 2005
    Location
    Melbourne, Australia
    Posts
    136

    Re: Fuel Gauge stopped working

    Not a bad call considering he will have to order it from another supplier.
    He has also stated that my minor cruise control issue is BeCM related. Cruise works fine however at hills it gradually slows down (I'm guessing this is NOT electrical...maybe I am wrong)

    I might need to change the badge on my car to your avatar Keith.
    1995 4.6 HSE :: 290,000km **New motor @ 280k **
    2.5" sports exhaust (head turning note
    Rhino alloy rack, Dual batteries,Toyo ATR's
    Tartarini injected LPG (72Lt donut)
    Camper Trailer with tinnie on roof
    2004 Yamaha WRF250

  13. #12
    SOPHOMORE ROVER
    Join Date
    October 16th, 2008
    Location
    Lincolnshire, UK
    Posts
    454

    Re: Fuel Gauge stopped working

    for the cost of a sender i would do the job myself and have words with the garage afterwards.

    You say the cruise slows down on hills, does the engine change down gear?
    If not it could be gearbox / transfer ecu (not clued up on these) post a new thread about the cruise and someone on here will have the answer

  14. #13
    zem
    zem is offline
    FRESHMAN ROVER
    Join Date
    May 22nd, 2005
    Location
    Melbourne, Australia
    Posts
    136

    Re: Fuel Gauge stopped working

    Doesn't change down gears. Will post a new thread. Cheers.
    1995 4.6 HSE :: 290,000km **New motor @ 280k **
    2.5" sports exhaust (head turning note
    Rhino alloy rack, Dual batteries,Toyo ATR's
    Tartarini injected LPG (72Lt donut)
    Camper Trailer with tinnie on roof
    2004 Yamaha WRF250

  15. #14
    SOPHOMORE ROVER
    Join Date
    September 16th, 2006
    Location
    South Wales U.K.
    Posts
    459

    Re: Fuel Gauge stopped working

    Quote Originally Posted by waveydavey
    That idea of ratchet straps from the chassis I like; I had to drop mine for the in tank pump and it's great fun balancing it on the jack.
    I also struggled to get the filler neck in and out ; high suspension setting helps then leave a door open of pull the relay.

    Last tip; get a tin of paint. The 'cradle' that holds the tank can really collect salt and cause corrosion; first thing as you get it off clean it and give it a coat of paint - what harm can it do?

    Good call I'll try the ratchet strap idea, there's some chassis black paint lurking in the back of my sisters garage too...
    South Wales Area Rep
    Range Rover Register
    www.rrr.co.uk
    95 Range Rover 4.6 HSE PowerFlow Stainless Exhaust...nice meaty V8 Rumble.

  16. #15
    LIFETIME CONTRIBUTOR
    Join Date
    June 14th, 2004
    Location
    Emu Plains, NSW, Australia
    Posts
    5,304

    Re: Fuel Gauge stopped working

    Quote Originally Posted by p38arover
    Mine hasn't worked for about 2 years. I replaced the pump and I think the aftermarket pump has a problem. I cut a hole through the floor and plugged in the old pump and the fuel gauge worked.

    I'll enlarge the hole and remove the pump from inside the car. My tank is a 155 litre aftermarket long range tank and is steel so I don't really want to drop the tank out.

    There is a page on the main site http://www.rangerovers.net/repairdetails/fuelpump4.html about cutting a hole in the floor but unfortunately the writer hadn't measured the distances from a couple of reference points to the centre of the pump so that we could accurately determine exactly where to cut the hole.

    I could give my measurements but I don't know if they are the same for a standard fuel tank.
    I pulled my fuel pump out yesterday and checked the float.

    The float is some kind of foam material. It had a split along each side and was saturated with petrol. when I squeezed the float, petro exuded from the foam.

    I put the old pump and the one I just took out into a bucket of petrol. The old float floated, vthe new one did not.

    So I swapped the float from my old pump to the new pump and will reinstall it tomorrow after I finish making a tool to tighten the clamping ring for the tank(the clamping ring is not the same as a standard fuel tank as I have an aftermarket long range tank fitted).

    On a side note, I have now taken measurements from a hole cut in the floor of a P38A with an OEM tank (thanks Andrew E) and will put that info up here and on the main site.
    Ron Beckett
    1995 Range Rover HSE 4.6 V8 auto
    2007 Yamaha XJR1300
    2006 Suzuki DL650 V-Strom

    RIP Bucko (1979-2008 - Riding on forever)
    http://p38arover.com/lee_pix/bike_caricature-avatar.jpg

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Similar Threads

  1. CD player stopped working
    By greenhuman in forum Range Rover Mark II / P38
    Replies: 6
    Last Post: September 21st, 2011, 03:05 AM
  2. Key fob randoml stopped working! help
    By bluemini300 in forum Range Rover Mark II / P38
    Replies: 0
    Last Post: August 22nd, 2011, 06:46 PM
  3. Fuel Gauge not working,indicates empty with light when full
    By 4.0ranger in forum Range Rover Mark II / P38
    Replies: 9
    Last Post: January 26th, 2010, 08:12 PM
  4. speakers stopped working
    By Forumnoob in forum Range Rover Sport / L320
    Replies: 5
    Last Post: May 20th, 2008, 11:36 AM
  5. Sunroof stopped working
    By in forum Range Rover Classic
    Replies: 4
    Last Post: July 21st, 2007, 10:29 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2