Heater and Blower Problems
NEWS
 

  1. Welcome to RangeRovers.net – General discussion forum for Range Rovers

    Welcome to RangeRovers.net - a website dedicated to all things Range Rovers.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join RangeRovers.net today!
     
+ Reply to Thread
Results 1 to 3 of 3

Thread: Heater and Blower Problems

  1. #1
    FRESHMAN ROVER
    Join Date
    March 26th, 2007
    Location
    California
    Posts
    30

    Heater and Blower Problems

    I can't fiqure out what is going on I've searched the board and still can't fiqure it out. My Blower is constantly on high and cannot be adjusted and my heater is blowing cold it sometimes starts working after about 20 minutes. My coolant level is OK and I replaced the thermostat and it made no difference. The testbook symbol is on, so what do you think? BTW there is no water in the footwells.

  2. Remove Advertisements
    RangeRovers.net
    Advertisements
     

  3. #2
    SITE ADMINISTRATOR RRToadHall's Avatar
    Join Date
    April 12th, 2006
    Location
    Maltby, WA USA
    Posts
    15,376

    Re: Heater and Blower Problems

    Have you checked and/or swapped your relays?
    Why don’t you ever see hippopotamus hiding in trees? ...because they’re REALLY good at it.

  4. #3
    SOLIHULL ROVER
    Join Date
    June 13th, 2006
    Location
    Kuala Lumpur
    Posts
    1,674

    Re: Heater and Blower Problems

    Hi

    Your description of the problem is not very clear. What do you want your system to do?? What are your settings??

    If you want heat and get it only after 20 minutes you might have a flow problem in your heater. Air might be trapped or coolant level might be low.

    You can not adjust your blower speed? Is it in manual control mode? If so then the small copper fingers at the inside of your dial might be broken off.
    Or there might be a wiring problem towards your blower motors.

    Jos
    1995 RR 4.0 SE
    Fitted with replacement engine and gearboxes from 1997 4.0 SE.

Similar Threads

  1. 92 Heater Blower Issues
    By rangie1444 in forum Range Rover Classic
    Replies: 4
    Last Post: November 2nd, 2010, 09:58 AM
  2. Heater blower relay
    By rich201283 in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: August 5th, 2009, 11:14 PM
  3. Heater/AC Blower Relay Problems
    By Bourbonrover in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: July 13th, 2008, 05:19 PM
  4. Heater Blower Motors
    By Jovinblak in forum Range Rover Mark II / P38
    Replies: 4
    Last Post: June 8th, 2008, 03:45 AM
  5. heater vs. A/C blower
    By rich in forum Range Rover Classic
    Replies: 2
    Last Post: December 12th, 2005, 12:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2